hero

FLUI

一个 Google Flutter 的 UI 框架

快速开始 →

丰富易用

拥有众多开箱即用的高质量 Flutter UI 组件,提供更加丰富的特性和功能,提高开发效率。

简易定制

细粒度非风格化的组件支持样式定制,满足个性化的产品需求。

高效反馈

用户操作会产生清晰的 UI 元素反馈,通过界面交互感知状态与场景。

# 直接使用 FLUI

# Add dependency in pubspec.yaml
flui: ^0.9.0

# Install
$ flutter pub get

# Use FLUI now
import 'package:flui/flui.dart'


# Dynamic 模块

FLUI-Dynamic 为动态渲染模块,支持根据 json 字符串或者指定类型的对象来渲染视图,更多介绍及使用方法可以查看 Dynamic

Widget buildDynamicWidget() {
    return FLDyContainer(
       jsonObject: $JSON_STRING_OR_OBJECT,
       placeholder: CircularProgressIndicator(
         strokeWidth: 3.0,
         valueColor: AlwaysStoppedAnimation(Theme.of(context).accentColor),
       ),
    );
}


提示

请确保 Flutter 的版本 >= 1.12.13+hotfix.8